Allan Duncan <amd2345(a)fastmail.com.au> writes:
On a Pi I got sick of having 3 versions of cpp so I
synaptic to remove the lot and then installed just 4.8. This worked
fine except I found that I needed to make symbolic links from cpp to
I haven't bothered to check, but these are probably provided by the
"cpp" package rather than the "cpp-4.N" package. The latter is
versioned such that e.g. cpp=4:4.7.2-1 Depends on cpp-4.7.
I now need to install libtool but synaptic wants to
also install cpp
(-4.6) without an option.
I see that libtool depends on cpp, so tell your package manager to
install the version of cpp that you want, not the version that is in
your target release. e.g.
bash4$ rmadison -aamd64 cpp
cpp | 4:4.4.5-1 | squeeze | amd64
cpp | 4:4.7.2-1 | wheezy | amd64
cpp | 4:4.9.1-5 | jessie | amd64
cpp | 4:4.9.2-1 | sid | amd64
apt-get install libtool cpp/jessie # or
apt-get install libtool cpp=4:4.9.1-5
Presumably you're on raspbian, where this may not be an option.
PS: mixing stable and testing is likely to break things.
I recommend you use the default cpp that your release ships, and stop
pining for newer versions.
I figured I could tell apt-get to forget about cpp and
just get on
with it (ie --nodeps in rpm),
but it doesn't seem to have such an option.
apt corresponds to yum, not rpm.
dpkg has corresponding --force-* commands.
If you use them, you WILL blow your foot off.